Mon réseau fonctionne avec OSPF sous IPv6, il y a deux domaines (domaine 1 -> R_Backbone_D1 et R_ASBR_D1, domaine 2 -> R_ASBR_D2 et R_Backbone_D2) Une interconnexion BGP relie ceux deux domaines via les routeurs R_ASBR_S1 et R_ASBR_D2.
Petit "schéma" :
R_Backbone_D1 <-> R_ASBR_D1 <-> Interconnexion BGP <-> R_ASBR_D2 <-> R_Backbone_D2
Le problème est que les paquets envoyé depuis le routeur R_Backbone_D1 n'atteignent pas le routeur R_Backbone_D2. Ces paquets passent pourtant l'interconnexion BGP et atteignent le routeur R_ASBR_D2, mais ne passent pas la dernière liaison. Je pense que le problème est par rapport au redistribution OSPF / BGP..
Configuration des routeurs :
- Code: Tout sélectionner
R_Backbone_D1
hostname R_Backbone_D1
!
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:2:2::1/64
ipv6 enable
ipv6 ospf 10 area 0
!
ipv6 router ospf 10
router-id 1.1.1.1
log-adjacency-changes
!
end
- Code: Tout sélectionner
R_ASBR_D1
hostname R_ASBR_D1
!
no ipv6 source-route
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:2:2::2/64
ipv6 enable
ipv6 ospf 10 area 0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:6:1::1/64
ipv6 enable
!
router bgp 100
bgp router-id 1.1.1.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:DB8:6:1::2 remote-as 100
!
address-family ipv6
neighbor 2001:DB8:6:1::2 activate
redistribute connected
redistribute ospf 10 match internal external 1 external 2
exit-address-family
!
ipv6 router ospf 10
router-id 1.1.1.2
redistribute bgp 100
log-adjacency-changes
!
end
- Code: Tout sélectionner
R_ASBR_D2
hostname R_ASBR_D2
!
no ipv6 source-route
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:4:2::2/64
ipv6 enable
ipv6 ospf 10 area 0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:6:1::2/64
ipv6 enable
!
router bgp 100
bgp router-id 2.1.1.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:DB8:6:1::1 remote-as 100
!
address-family ipv6
neighbor 2001:DB8:6:1::1 activate
redistribute connected
redistribute ospf 10 match internal external 1 external 2
exit-address-family
!
ipv6 router ospf 10
router-id 2.1.1.2
redistribute bgp 100
log-adjacency-changes
!
end
- Code: Tout sélectionner
R_Backbone_D2
hostname R_Backbone_D2
!
no ipv6 source-route
ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:4:2::1/64
ipv6 enable
ipv6 ospf 10 area 0
!
ipv6 router ospf 10
router-id 2.1.1.1
log-adjacency-changes
!
end
Je suis au votre disposition si mes explications n'ont pas assez été clair, merci d'avance !!